←TopPage>eclipseで開発>eclipse2.0.2>Debian Linuxにインストール


Debian Linuxにインストール

なんでDebianにeclipseなの?

なんたって、おうちにある一番速いマシンは、おうちサーバだからなぁ

「やっぱりIDEは、性能の良いマシンじゃないと、使い勝手が悪いだろう」

ってことで、Debianマシンにeclipseをインストールすることにした。

Debianやeclipseのバージョンは?

ここでは、eclipse2.0.2をDebian 3.0(Woody)にインストールしてみます。 2003/3/31にeclipse 2.1がリリースされたので、eclipse 2.0.2は、最新のバージョンではありません。

Debian(Woddy = 3.0だっけ)で、eclipseしてみました。
eclipseの方は、ちょうど、2003年1月7日に最新版の日本語バンドルも出たようだし、タイミングばっちし。
安定志向の私は、eclipse Latest Release 2.0.2で挑戦。

じつは、Debian(surge=テスト版)だと、eclipse-jp-mlで、おかもとさんという方が、debパッケージまで作ってくれているんですが…

参照: http://www.egroups.co.jp/message/eclipse-ml/260?threaded=1

From:  toraneko@k...
Date:  2002年12月15日 (日)  午後0時57分
Subject:  Linux で Eclipse

deb http://ftp.debian.org/debian/ testing main non-free contrib
deb http://people.debian.org/~tora/deb ./

おうちサーバはスータブルバージョンのWoddyで、常時使っているからDebianのテストバージョンに上げて不安定になっても困るので、これは使わず/usr/local/eclipse/に自力でインストールすることにした。

はたまた1月12日に調べてしたら、*1でびあんでじゃば」で、 Woodyに対応した、debを作ってくれているそうです。

http://people.debian.org/~tora//deb/

うーむ Woodyなら安心なので、こちらもトライしてみようかなぁ。 なんて思ったんだけど、おなじ場所じゃん!!

注:この文書は、Debian 3.0(Woody)以上に対応しています。

ってあるので喜んじゃったけど たぶん、MLの方が新しいから、Webは更新されていないだけかな〜(;_;) MLで聞いてみよーっと

さて、インストールだ!!

インストール方法は、簡単で「ファイルを展開すれば終わり」なので、 @ITの「連載 Eclipseを使おう!(1)」 などを参考にして下さい。

@ITの記事は、1月7日より前なので、最新版の日本語バンドルではありません。 エクリプス:日本語化では、 最新のファイルでの説明になっています。*2

起動も出来ないぞ!!

ファイルを展開て、展開先にあるeclipseコマンドを起動しても、うまく立ち上がりません。 「libXm.so.2が無い」とかいわれちゃうので、LD_LIBRARY_PATHに、eclipse homeを 通すと、少し進みます。

起動時に、カレントディレクトリーにworkspaceを作るので、workspaceを 作りたい場所で、コマンドを起動しないと、変な所にworkspaceが出来て困ります。 起動コマンドラインのオプション -data で、workspaceの位置を指定できるので、

私は

alias eclipse='LD_LIBRARY_PATH=/usr/local/eclipse \
 /usr/local/eclipse/eclipse \
 -data ~/src/eclipse/workspace'

というaliasを作っています。*3

GTK版では問題たくさん

はじめはGTK 2.0に対応した、

Linux RH7.1/SuSE7.1(x86/GTK 2) eclipse-SDK-2.0.2-linux-gtk.zip

を使っていたんだけど、なんか環境設定で、うまくボタンが押せなくて、JREの設定とかが出来ない(;_;

「日本語バンドルが悪いのかな」とか思って、古い日本語バンドルにしたり、英語版のまま使ったりしたけど、どうもうまくいきません。

なんかGTKの設定が悪いような気がして、

Linux RH7.1/SuSE 7.1(x86/Motif) eclipse-SDK-2.0.2-linux-motif.zip 

にしたら、なんのことはない、ちゃらっと動きました。

ただし、いくらか文字が化けちゃうところがあるけどね。 これは、GTKではできないというEditorで日本語入力も、ちゃんとできるしMotifで満足としています。(あ、日本語の入力はできるのですが、フォントの選択が悪いのか表示は出来ません。)

GTK版の方が、画面がきれいだし、ホイルンマウスも有効になるから、うまく使えるものならば移行したいので、Debianで出来た人いたら教えて下さい。

せっかくGTK2.0をapt-getしたのにな…(結局いまはremoveしたけど)
いまだ、かっこいいXwindows User I/Fに成れない人でした(-_-;

Helpが変だ

Helpで日本語での検索が出来ません。 @ITの記事の「日本語化の際の問題点」で、修正版のhelp.jarが手にはいるので、置き換えると良いと思います。

わたしは、置き換えたけど、うまくいかないんですが…

まーなんとか使えるようになりました。

#ref(): The style ref(filename,pagename) is ambiguous and become obsolete. Please try ref(pagename/filename)


←TopPage>eclipseで開発>eclipse2.0.2>Debian Linuxにインストール


*1 いや、本当はDebain&JBOSSで検索しててみつけたのですが
*2 こちらはPukiWikiなので、いつリンクがなくなるか分からないけど。
*3 workspaceにすべてのプロジェクトが入るので、workspaceを一カ所に固定していると、そのうちうざくなりそうですが…

添付ファイル: fileeclipse.gif 877件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2003-07-20 (日) 02:25:38 (5722d)