←TopPage>eclipseで開発>Debian Linuxにインストール

#navi(eclipseで開発): Not a child page like: eclipseで開発/eclipseをDebianにインストール

Debian Linuxにインストール

なんでDebianにeclipseなの?

なんたって、おうちにある一番速いマシンは、おうちサーバだからなぁ

「やっぱりIDEは、性能の良いマシンじゃないと、使い勝手が悪いだろう」

ってことで、Debianマシンにeclipseをインストールすることにした。

Debianやeclipseのバージョンは?

Debian 3.0(Woddy)で、eclipseしてみました。 eclipseの方は、2003年3月31日に公開されたeclipse 2.1です。 安定志向の私は、eclipse Latest Releaseで挑戦します。

じつは、Debian(surge=テスト版)だと、eclipse-jp-mlで、おかもとさんという方が、debパッケージまで作ってくれているんですが…

参照: http://www.egroups.co.jp/message/eclipse-ml/260?threaded=1

From:  toraneko@k...
Date:  2002年12月15日 (日)  午後0時57分
Subject:  Linux で Eclipse

deb http://ftp.debian.org/debian/ testing main non-free contrib
deb http://people.debian.org/~tora/deb ./

おうちサーバはスータブルバージョンのWoddyで、常時使っているからDebianのテストバージョンに上げて不安定になっても困るので、これは使わず/usr/local/eclipse/に自力でインストールすることにした。

はたまた1月12日に調べてしたら、*1でびあんでじゃば」で、 Woodyに対応した、debを作ってくれているそうです。

http://people.debian.org/~tora//deb/

うーむ Woodyなら安心なので、こちらもトライしてみようかなぁ。 なんて思ったんだけど、おなじ場所じゃん!!

注:この文書は、Debian 3.0(Woody)以上に対応しています。

ってあるので喜んじゃったけど たぶん、MLの方が新しいから、Webは更新されていないだけかな〜(;_;) MLで聞いてみよーっと

さて、インストールだ!!

基本的には、本体と日本語バンドルをダウンロードしてきてunzipで展開するだけです。

Linux (x86/Motif) (Supported Versions) (http)   (ftp) eclipse-SDK-2.1-linux-motif.zip 

Language Pack: 2.0 January 7, 2003.

ダウンロードしてくると良いでしょう。

また、eclipse 2.1でのメニューの日本語化は、 @ITプロダクトレビューEclipse 2.1 の「COLUMN Eclipseの日本語化」にあるファイルをダウンロードしてきて展開すればできます。

http://people.debian.org/~tora/tmp/eclipse-2.1-NLS-menu.zip

インストール参考資料

インストール方法は、簡単で「ファイルを展開すれば終わり」なのですが、 @ITの「連載 Eclipseを使おう!(1)」 なども参考になります。

ただし、この@ITの記事は、eclipse 2.1以前の話なので最新版の日本語バンドルではありません。また、LinuxでのHelpで検索出来ない問題もeclipse 2.1では解決されているので、Helpのパッチを当てる必要はありません。

参考として、エクリプス:日本語化に最新のファイルでの説明があります。*2

起動も出来ないぞ!!

ファイルを展開て、展開先にあるeclipseコマンドを起動しても、うまく立ち上がりません。 「libXm.so.2が無い」とかいわれちゃうので、LD_LIBRARY_PATHに、eclipse homeを 通すと、少し進みます。

起動時に、カレントディレクトリーにworkspaceを作るので、workspaceを 作りたい場所で、コマンドを起動しないと、変な所にworkspaceが出来て困ります。 起動コマンドラインのオプション -data で、workspaceの位置を指定できるので、

私は

alias eclipse='LD_LIBRARY_PATH=/usr/local/eclipse \
 /usr/local/eclipse/eclipse \
 -data ~/src/eclipse/workspace'

というaliasを作っています。*3

GTK版は問題たくさん

実は、はじめはeclipse 2.0.2でも挫折したGTK 2.0に対応した、

Linux (x86/GTK 2) (Supported Versions) (http)   (ftp) eclipse-SDK-2.1-linux-gtk.zip 

みを使おうとしたのですが、これで要求されている環境は、  Other Linux; GTK 2.0.6 (GTK 2.2 required for DBCS) です。Debian 3.0では、残念ながら起動する事は出来ませんでした。 私の環境でdebが足りないだけかもしれませんが…

なんかGTKの設定が悪いような気がして、

Linux (x86/Motif) (Supported Versions) (http)   (ftp) eclipse-SDK-2.1-linux-motif.zip 

にしたら、なんのことはない、eclipse2.0.2の時と同様にちゃらっと動きました。

eclipse 2.0.2とは違い文字が化けもありませんし、フォントを選択すれば、日本語の入出力には問題が無くなりました。

GTK版の方が、画面がきれいだし、ホイルンマウスも有効になるから、うまく使えるものならば移行したいので、Debianで出来た人いたら教えて下さい。

まーなんとか使えるようになりました。

#ref(): The style ref(filename,pagename) is ambiguous and become obsolete. Please try ref(pagename/filename)

次は

文字列のリソースバンドル化 」で、eclipseでテストプログラムを作ってみましょう。

すぐにJ2EEする人は、eclipseでJ2EE開発入門のページ「 J2EEみんとす 」へ

←もくじに戻る

#navi(eclipseで開発): Not a child page like: eclipseで開発/eclipseをDebianにインストール

←TopPage>eclipseで開発>Debian Linuxにインストール


*1 いや、本当はDebain&JBOSSで検索しててみつけたのですが
*2 こちらはPukiWikiなので、いつリンクがなくなるか分からないけど。
*3 workspaceにすべてのプロジェクトが入るので、workspaceを一カ所に固定していると、そのうちうざくなりそうですが…

添付ファイル: fileeclipse2.1.png 1401件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2003-07-20 (日) 02:27:29 (5206d)