←TopPage>eclipseで開発>eclipse2.0.2>Lombozインストール


Lombozインストール

はじめに

eclipse 2.0.2に対応しているのはLomboz 0.97です。

2003/3/31のeclipse 2.1公開と同時にLombozもLomboz 2.1が公開されたので、ここで説明しているLomboz 0.97は最新ではありません。

Lomboz 0.97では、XDoclet 1.1.2をベースとしていましたが、Lomboz 2.1ではXDoclet 1.2b2ベースになり、対応しているアプリケーションサーバが増えています。

Fileを持ってきて展開する

プラグインなので、インストールは、いつもの通りZIPファイルを展開するだけです。
http://www.mycgiserver.com/~objectlearn/products/lomboz.html
http://sourceforge.net/projects/lomboz からダウンロードして来て、eclipseをインストールしたディレクトリーで展開。

Lombozの環境設定をする

さて、eclipseを起動すると、プラグインが読み込まれるので、 環境設定をします。

パースペクティプのカスタマイズ

メニュー「ウィンドウ」→「パースペクティプのカスタマイズ」で出てくる ダイアログの中で、「ファイル>新規」を広げて、

  • Lomboz EJB Wizard (実物ではLomboz EJB Creation Wizardでした)
  • Lomboz New EJB Method (実物ではLomboz EJB Method Wizardでした)
  • Lomboz EJB Test Client Wizard
  • Lomboz J2EE Container
  • Lomboz J2EE Project

にチェックをつけます。

そのまま、「その他」も開いて

  • Lomboz Actions

にもチェックをつけます。

また、「ウィンドウ>ビューの表示」では

  • Lomboz J2EE View

のチェックをつけます。

「OK」を押して設定を終えると、ツールバーにJ2EE Project Outlinerが開く四角いちっちゃなn道具箱が出てきます。

このアイコンなどは、Install.pdfで確認してください。

環境設定

JDTと連携するための設定

メニュー「ウィンドウ」→「設定」で設定ダイアログを出して 「Java」-「新規プロジェクト」を開きます。 ここで、ソースとバイナリの入れ場所としてフォルダーを選択して それそれの出力先をsrcbinとします。

これらのフォルダー名をLabbozでは、変更することが出来ません。

JREの設定

すでにJavaでの開発をeclipseで行っていれば設定されていると思いますが、「ウィンドウ」→「設定」で「Java」-「インストール済みのJRE」で、JREの場所を設定する必要があります。

Lombozの環境設定

そのまま「Lomboz」を開きます。

ここで、JDK Tools.jarに、JDKのtools.jarの場所を登録する必要があります。 DebianでJ2SE 1.3ならば/usr/lib/j2sdk1.3/lib/tools.jarですね。

AP Serverの指定です。

つぎに「Lomboz」を展開して、Application Serverの指定です。 とりあえず、私はtomcat4にしておきました。

Server Home Directory
/usr/share/tomcat4
Version
4.0.3/4.0.4 (Debian 3.0 Woodyなら)

としておけば、良いかな〜

クラスパスの確認

最後に、「Java」-「クラスパス変数」に上記で設定した JBOSS,TOMCAT,WEBLOGICの値が正しく入力されているか確認して、 「OK」ボタンを押して 環境設定は終わりです。

docletするならば…

Java2ならば、docletが出来ます。 設定のダイアログで、「Java」-「Javadoc」で Javadocコマンドの位置を/usr/bin/javadocと正しく指定して下さい。

J2EE RIを利用するための設定

JBOSSではなくてJ2EE RIを利用する場合には以下の環境変数を設定しておくと 便利です。

環境変数として、J2EE RIのためにJ2EE_HOMEを追加しておきます。 「ウインドウ」→「設定」で、「Java」→「クラスパス変数」を 選択します。 「新規」で、J2EE_HOMEとして、J2EE RIのインストール先 /usr/local/j2sdkee1.3.1 を追加してください。

#ref(): The style ref(filename,pagename) is ambiguous and become obsolete. Please try ref(pagename/filename)

参考資料


←TopPage>eclipseで開発>eclipse2.0.2>Lombozインストール


添付ファイル: fileJ2EE_HOME.gif 925件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2003-07-20 (日) 02:26:24 (5600d)